Contents
  1. 1. 输入格式:
  2. 2. 输出格式:
  3. 3. 输入样例:
  4. 4. 输出样例:
  5. 5. 分析:
  6. 6. 代码:

为了用事实说明挖掘机技术到底哪家强,PAT 组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式:

输入在第 1 行给出不超过 105 的正整数 N,即参赛人数。随后 N 行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从 1 开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式:

在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。

输入样例:

6
3 65
2 80
1 100
2 70
3 40
3 0

输出样例:

2 150

分析:

map键值对中键是唯一的,所以根据键去增加值,然后找到其中最大值即可。

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
#include<iostream>
#include<map>
using namespace std;
int main(){
int n,id,score,max_id,max_score=0;
map<int,int> m;
map<int,int>::iterator it;
cin >> n;
while (n--){
cin >> id >> score;
m[id]+=score;
}
for (it=m.begin();it!=m.end();it++){
if (max_score < it->second){
max_id = it->first;
max_score = it->second;
}
}
cout << max_id << " " << max_score;
return 0;
}
Contents
  1. 1. 输入格式:
  2. 2. 输出格式:
  3. 3. 输入样例:
  4. 4. 输出样例:
  5. 5. 分析:
  6. 6. 代码: