Contents
  1. 1. 输入格式:
  2. 2. 输出格式:
  3. 3. 输入样例:
  4. 4. 输出样例:

给定一个长度不超过 104 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest.... 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过 104 的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

1
redlesPayBestPATTopTeePHPereatitAPPT

输出样例:

1
PATestPATestPTetPTePePee
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
#include<iostream>
#include<map>
#include<vector>
using namespace std;
int main(){
string s;
int length,count=0;;
map<char,int> m;
vector<int> v(6);
char dict[6] = {'P','A','T','e','s','t'};
cin >> s;
length = s.size();
for (int i=0;i<length;i++){
if (s[i] == 'P' || s[i] == 'A' || s[i] == 'T' || s[i] == 'e' || s[i] == 's' || s[i] == 't'){
m[s[i]]++;
count++;
}
}

for (int i=0;i<6;i++)
v[i] = m[dict[i]];

while (count){
for (int i=0;i<6;i++){
if (v[i]){
cout << dict[i];
v[i]--;
count--;
}
}
}
return 0;
}

Contents
  1. 1. 输入格式:
  2. 2. 输出格式:
  3. 3. 输入样例:
  4. 4. 输出样例: