Contents
  1. 1. 输入格式:
  2. 2. 输出格式:
  3. 3. 输入样例:
  4. 4. 输出样例:

火星人是以 13 进制计数的:

  • 地球人的 0 被火星人称为 tret。
  • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

1
2
3
4
5
4
29
5
elo nov
tam

输出样例:

1
2
3
4
hel mar
may
115
13
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include<iostream>
using namespace std;
int main(){
string s,dict1[13] = {"tret","jan","feb","mar","apr","may","jun","jly","aug", "sep", "oct", "nov", "dec"},
dict2[12] = {"tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};;
int n,temp;
cin >> n;
getchar();
for (int i=0;i<n;i++){
getline(cin,s);
if (s[0] >= '0' && s[0] <= '9'){
temp = stoi(s);
if (temp<=12) cout << dict1[temp];
else if (temp%13 == 0) cout << dict2[temp/13-1] ;
else cout << dict2[temp/13-1] << " " << dict1[temp%13];
}
else {
if (s.size() == 3){
//0-12
for (int i=0;i<13;i++)
if (s == dict1[i]) cout << i;
//13整数倍
for(int i=0;i<12;i++){
if (s == dict2[i])
cout << (i+1)*13 ;
}
}
//其他
else {
int m=0;
string first,second;
first = s.substr(0,3);
second = s.substr(4,3);
for (int i=0;i<13;i++)
if (second == dict1[i]) m += i;
//13整数倍
for(int i=0;i<12;i++)
if (first == dict2[i]) m += (i+1)*13;
cout << m;
}
}
if (i != n-1) cout << endl;
}
return 0;
}

Contents
  1. 1. 输入格式:
  2. 2. 输出格式:
  3. 3. 输入样例:
  4. 4. 输出样例: