Contents
  1. 1. Input Specification:
  2. 2. Output Specification:
  3. 3. Sample Input 1:
  4. 4. Sample Output 1:
  5. 5. Sample Input 2:
  6. 6. Sample Output 2:
  7. 7. Sample Input 3:
  8. 8. Sample Output 3:

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

题目大意:给出n个学生的信息(id+name+grade),按照要求C排序。如果C为1,则按照id升序排列;如果C为2,按照名字非降序排列;如果C为3,按照成绩非降序排列。(名字或成绩一样的时候按照id升序排列)。

分析:按题目要求写三个cmp即可。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
struct node{
string id,name,grade;
};
bool cmp1(node a,node b){ return a.id < b.id;}
bool cmp2(node a,node b){ return a.name != b.name ? a.name < b.name : a.id < b.id;}
bool cmp3(node a,node b){ return a.grade != b.grade ? a.grade < b.grade : a.id < b.id;}
int main(){
int n,flag;
cin >> n >> flag;
vector<node> v(n);
for(int i=0;i<n;i++)
cin >> v[i].id >> v[i].name >> v[i].grade;
if (flag == 1) sort(v.begin(),v.end(),cmp1);
else if (flag == 2) sort(v.begin(),v.end(),cmp2);
else sort(v.begin(),v.end(),cmp3);
for(int i=0;i<n;i++)
cout << v[i].id << " "<< v[i].name << " " << v[i].grade << endl;
return 0;
}
Contents
  1. 1. Input Specification:
  2. 2. Output Specification:
  3. 3. Sample Input 1:
  4. 4. Sample Output 1:
  5. 5. Sample Input 2:
  6. 6. Sample Output 2:
  7. 7. Sample Input 3:
  8. 8. Sample Output 3: